Nasze strony wykorzystują pliki cookies. Używamy cookies i podobnych m.in. w celach reklamowych i statystycznych oraz w celu dostosowania serwisów do potrzeb użytkowników. Mogą też stosować je nasi reklamodawcy, firmy badawcze oraz dostawcy aplikacji. W przeglądarce można zmienić ustawienia dotyczące cookies. Więcej informacji. Jeśli nie wyrażasz zgody, opuść tę stronę.

Pajączek 5.1.0 a Unicode

Forum dyskusyjne poświęcone programowi Pajączek 5 NxG. Wysyłaj tutaj tylko wiadomości dotyczące tego programu.

Moderator: Grupa pościgowa ;-)

Pajączek 5.1.0 a Unicode

Postprzez gucio » 10 września 2003, o 22:33

gucio
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 6
Dołączył(a): 13 października 2002, o 21:16

tak jest ... a nawet gorzej :((

Postprzez zpluta » 12 września 2003, o 17:23

zpluta
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 8
Dołączył(a): 13 stycznia 2003, o 23:12

Postprzez platekr » 12 września 2003, o 23:42

W 5.1.0 doszło wiele opcji związanych z kodowaniem edytowanych dokumentów. Nie jestem pewien, czy to co opisujesz (zpluta) jest związane z błędem czy niepoprawną konfiguracją (niepełną). Obecnie dokument zapisywany jest w róznym kodowaniu zależnie od kilku opcji:

Jeśli dokument nie ma przypisanego własnego kodowania pamiętanego w pliku ADD i ustawianego przez menu PISOWNIA/ZAPISUJ W KODOWANIU, to używane jest:

* jeśli dokument nie należy do żadnego serwisu WWW, to używane są kodowania domyślne z Ustawień/Edytor/Dokumenty/Domyślne kodowanie przy zapisie

* jeśli dokument należy do serwisu, to używane są kodowania domyślne serwisu ustawione w Własności serwisu/Dokumenty

* jeśli dokument należy do serwisu, a ten nie ma przypisanych domyślnych kodowań, to używane są kodowania domyślne z Ustawień/Edytor/Dokumenty/Domyślne kodowanie przy zapisie

Jeśli dokument ma ustawione własne kodowanie w pliku ADD (menu Pisownia/Zapisuj w kodowaniu), to to ustawienie ma priorytet nad wszystkimi innymi podrzędnymi ustawieniami tj. ustawieniami domyślnego kodowania w serwisie, do którego należy dokument i w ustawieniach.

Co do zgłoszenia gucia, to mam pytanie, czy przy kopiowaniu przez schowek z notatnika i wklejeniu do Pajączka od razu z polskich znaków robią się krzaki, czy dopiero przy zapisie. Czy możemy prosić o wystawienie gdzieś pliku, który otwierasz w notaniku i na pracy z którym można zaobserwować te problemy ?
platekr
Administrator forum
Administrator forum
 
Posty: 1744
Dołączył(a): 8 września 2002, o 22:48
Lokalizacja: Myslenice, Poland

OK

Postprzez zpluta » 13 września 2003, o 12:40

zgadza się - dopiero potem zauważyłem, że opisywane zjawisko miało miejsce dla plików includowanych do innych, więc nie miały one zadeklarowanego kodowania (a gdzie indziej też tego nie ustawiałem) ... pogrzebałem w ustawieniach i wymusiłem "nasze ISO" a teraz widzę że były też inne możliwości - bardzo dziękuję ...
zpluta
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 8
Dołączył(a): 13 stycznia 2003, o 23:12

Postprzez gucio » 15 września 2003, o 11:20

W tej chwili (po wielu próbach konfiguracji programu) przy wklejeniu przez schowek wszystko jest OK, podgląd w przeglądarce również w porządku. Dopiero po ponownym otwarciu dokumentu w Pająku znikają diakrytyki (tym razem nie polskie, tylko 'zagraniczne').
W poprzedniej konfiguracji 'zagraniczne' były OK, polskie od razu po wklejeniu wyświetlały się jako japońskie (a może chińskie?).

Z pewnością wina leży w złej konfiguracji (mam nadzieję). Próbuję metodą prób i błędów dojść do sedna sprawy. Odezwę się.

gucio

PS. Czy nie lepiej (prościej) byłoby, aby Pająk odczytywał deklarację kodowania w dokumencie i zapisywał domyślnie w tym samym kodowaniu? Dopiero kiedy brak deklaracji META, wtedy obowiązywałyby ustawienia programu.
gucio
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 6
Dołączył(a): 13 października 2002, o 21:16

Postprzez gucio » 19 września 2003, o 10:04

Kilkanaście prób z różnymi ustawieniami i ****
W Pająku widoczne wszystkie diakrytyki, również po ponownym otwarciu dokumentu, w przeglądarce (lub Notatniku) zamiast polskich robaków krzaki i to zarówno te wpisane w Pająku jak i skopiowane przez schowek.

gucio
gucio
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 6
Dołączył(a): 13 października 2002, o 21:16

Postprzez platekr » 22 września 2003, o 21:50

platekr
Administrator forum
Administrator forum
 
Posty: 1744
Dołączył(a): 8 września 2002, o 22:48
Lokalizacja: Myslenice, Poland

Postprzez gucio » 22 września 2003, o 22:18

Ustawienia: nie konwertuj znaków narodowych przy otwieraniu, nie konwertuj znaków narodowych przy zapisie, kodowanie UTF-8.
Efekt: polskie znaki wpisane w Pajączku są poprawnie wyświetlane w edytorze, ale w przeglądarce są wyświetlane po chińsku.
Znaki esperanckie przy wklejaniu przez schowek zamieniają się na encje i wyświetlane są prawidłowo.
Załączniki wysyłam emalią.

g u c i o
gucio
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 6
Dołączył(a): 13 października 2002, o 21:16

Postprzez platekr » 23 września 2003, o 20:47

platekr
Administrator forum
Administrator forum
 
Posty: 1744
Dołączył(a): 8 września 2002, o 22:48
Lokalizacja: Myslenice, Poland

Postprzez gucio » 23 września 2003, o 21:40

gucio
Zanim zapytam poszukam odpowiedzi
Zanim zapytam poszukam odpowiedzi
 
Posty: 6
Dołączył(a): 13 października 2002, o 21:16


Powrót do Pajączek 5 NxG

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników

cron