Nasze strony wykorzystują pliki cookies. Używamy cookies i podobnych m.in. w celach reklamowych i statystycznych oraz w celu dostosowania serwisów do potrzeb użytkowników. Mogą też stosować je nasi reklamodawcy, firmy badawcze oraz dostawcy aplikacji. W przeglądarce można zmienić ustawienia dotyczące cookies. Więcej informacji. Jeśli nie wyrażasz zgody, opuść tę stronę.

Problem przy konwersji z ISO-2 na UTF-8

Forum dyskusyjne poświęcone programowi Pajączek 5 NxG. Wysyłaj tutaj tylko wiadomości dotyczące tego programu.

Moderator: Grupa pościgowa ;-)

Problem przy konwersji z ISO-2 na UTF-8

Postprzez Krzychud » 10 listopada 2004, o 13:45

Niby wszystko jest OK bo widać polskie znaki, ale na początku strony dodaje amp#65279; (amp to symbol &). Co ciekawe nie widać tego w edytowanym dokumencie tylko dopiero w przeglądarce (skąd się tam bierze???). Efekt nie jest miły bo tracę całe formatowanie.
Krzychud
Jeszcze się uczę
Jeszcze się uczę
 
Posty: 10
Dołączył(a): 10 listopada 2004, o 13:34

Postprzez platekr » 10 listopada 2004, o 20:23

Domyślam się, że to pewnie w PHP i przy przeglądaniu przez serwer. Starsze wersje PHP nie radzą sobie z 3-bajtowym nagłówkiem dokumentów Unicode, który jest dodawany przez Pajączka do plików UTF. Jest to zgodne ze specyfikacją Unicode. Mimo to umieściliśmy w programie opcję pozwalającą na wyłacznie dopisywania tego nagłówka przy zapisie dokumentów. Sprawdź w Ustawienia / Edytor / Dokument / Zapisywanie dokumentów.
platekr
Administrator forum
Administrator forum
 
Posty: 1744
Dołączył(a): 8 września 2002, o 22:48
Lokalizacja: Myslenice, Poland

Postprzez Krzychud » 15 listopada 2004, o 12:26

Dzięki - pomogło.
Ale sprawa jest chyba poważniejsza - serwer php jest w wersji 4.3.4, a edycja pliku na serwerze np. przez shh, też powoduje taki efekt. No i najważniejsze: taki sam efekt wystepuje przy zwykłych plikach html.
Krzychud
Jeszcze się uczę
Jeszcze się uczę
 
Posty: 10
Dołączył(a): 10 listopada 2004, o 13:34


Powrót do Pajączek 5 NxG

Kto przegląda forum

Użytkownicy przeglądający ten dział: Brak zidentyfikowanych użytkowników

cron